
Copyright ©  by rigi.io. All Rights Reserved.

Rigi for Passolo for
Translators
Version 2.108 (21 April 2020)

Rigi.io - Localization Platform



Rigi for Passolo for Translators

Page 2 of 53

Table of contents

Rigi for Passolo for Translators ............................................................................ 3
Context ......................................................................................................... 4
Text display ................................................................................................... 5
Comments in the string list ............................................................................. 6

Installation ........................................................................................................ 7
Prerequisites .................................................................................................. 8
Install SDL Passolo Translator Edition ............................................................... 9
Install the addin ........................................................................................... 10

Prepare translation project ................................................................................ 12
Access to previews ....................................................................................... 13

Server ..................................................................................................... 13
Offline .................................................................................................... 13

Split bundles ................................................................................................ 14
Translate ......................................................................................................... 15

Checklist ..................................................................................................... 16
Translate the bundle ..................................................................................... 17

Translation helpers ................................................................................... 20
Translation assistant ............................................................................. 20
Translation memories ........................................................................... 22

Setup .............................................................................................. 22
Update ............................................................................................ 24

Fuzzy and concordance search ............................................................... 26
Fuzzy matches ................................................................................. 26

Setup .......................................................................................... 27
Using fuzzies ............................................................................... 28

Concordance search .......................................................................... 29
Recycle bin ...................................................................................... 30

Updates on source text ......................................................................... 30
Pre-translation ..................................................................................... 31
Terminology ........................................................................................ 34

Rigi Dashboard ............................................................................................ 36
Layout .................................................................................................... 36
Views ...................................................................................................... 36

Rigi server ........................................................................................... 36
Live .................................................................................................... 38
Translate (offline) ................................................................................. 39
Review (offline) .................................................................................... 40

Quality check and delivery ............................................................................. 41
Tips and tricks for translators ............................................................................ 43

Special characters ......................................................................................... 44
Translation progress bar ............................................................................... 45
Search function ............................................................................................ 46
Navigation between strings ............................................................................ 48
Sorting strings ............................................................................................. 49
Filter for strings ........................................................................................... 50
Copying a placeholder or a tag ...................................................................... 51

Known issues ................................................................................................... 52
Filtering may freeze Passolo .......................................................................... 53



Rigi for Passolo for Translators

Page 3 of 53

Rigi for Passolo for Translators

This manual describes how translators can translate Rigi projects in software localization
tool SDL Passolo.

What is Rigi for SDL Passolo?

SDL Passolo is a professional software localization tool. The Project Manager creates
translation bundles that translators can open in the (free) SDL Passolo Translator Edition.
The scope of this document is to explain how to translate the strings provided in the bundle.

Rigi provides an add-in for SDL Passolo (i.e.  Rigi addin for SDL Passolo). The add-in
enables translators to localize dynamic applications in context. Examples of such
applications are web based applications and WPF. If you as a translator select a text in the
translation environment, then the preview in Passolo will immediately show the preview with
the available translations (What You See Is What You Get).

When you open the bundle in Passolo, you will see one string list that contains all strings in
a project. The goal is to translate the untranslated strings.

String list in Passolo contains all software strings that are used in the web application
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Context

The challenge for translators is to have context about the string that must be translated. For
example, should you translate the word “Note”, like a ‘Bill̓  or as an ‘annotationʼ?

How to translate the string “Note”?

The  Rigi addin for SDL Passolo shows a preview (if available) with the selected text for a
selected string. 

"Note" in the context of "Annotation"

Besides this preview, the Rigi environment offers more options to provide context:
· Live website
· Comments
· Text display
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Text display

The text display shows the source document and the string within that document. The
location of the text in the source file could provide you additional information. 

Certain file formats support a text display. In this case, you will see the Text Display tab at
the right in the Passolo preview window. 

Please note that this functionality is extremely helpful for those file types where developers
use comments. In case no comments are available, it shows the list of key/value pairs only.
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Comments in the string list

Comments may be added for certain strings in the project, these can provide linguistic
comments/translation instructions as additional context to support precise translation:

There are two types of comments:
1. Comments by the developers. These are part of the source files. Translators can see

them in the Text Display. 
2. Linguistic comments/Translation instructions. can be seen in the Comment column in

Passolo.
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Installation

You can find here information about the prerequisites and how to install and license the Rigi
solution parser.
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Prerequisites

The prerequisites to use the  Rigi addin for SDL Passolo are:

1. Install the SDL Passolo Translator Edition, see Install SDL Passolo Translator Edition.

2. Install the  Rigi addin for SDL Passolo, see Install the addin.
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Install SDL Passolo Translator Edition

You need to install the free SDL Passolo Translator Edition to localize Passolo projects
from your client. The version of the translator edition must match the version of the bundle.
For example, you need version 2016 to localize a bundle that has extension .tublic16.
You can install all versions of the Translator Edition on one computer without interference.

1. Download the installer from the SDL web site.

2. Install SDL Passolo Translator Edition.

http://www.translationzone.com/products/passolo/translator-edition.html
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Install the addin

The steps to install the  Rigi addin for SDL Passolo are:

1. Close Passolo.

2. Execute the installer: rigi_passolo_Setup_N.nn.exe, where N.nn the version
of the addin.

This is a universal installer for the Team, Professional and Translator editions of
Passolo.

3. Select the version of Passolo for which you want to install the addin.

Make sure to select the Translator edition.

4. Verify that the path is correct.
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The addin will be installed in a subfolder of the Passolo System folder.

5. Open Passolo.

The Tools menu now shows the addin:
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Prepare translation project

The project manager sent a Passolo translation bundle (extension .tbulicnn). The
translation bundle contains all texts of the project. The texts that must be translated are
marked as "untranslated". You can enter translations using the SDL Passolo Translator
Edition. When ready, you can return the bundle with the translations to the project manager.

In most cases, you can start translating, see section Translate.

However, please pay attention to the following:
· Make sure that you have access to the previews for context.
· If the bundles are too large, then you can request the project manager to split the bundle

over more translators, see Split bundles.
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Access to previews

One of the key features of Rigi is that translators have context in the form of a preview when
they select a string to be translated. Previews are stored:
· On the Rigi server, or
· Offline.
Server

Most projects have the previews stored on the Rigi server. Translators can access those
previews from within Passolo after they have entered their credentials.

1. Sign up for an account on the server for your project: xyz.rigi.io (ask your project
manager for the details):

Offline

In some cases, the project does not support the storage of previews on the Rigi server. In
those cases, the project manager provides a ZIP file with all previews. 

1. Extract that ZIP file in a subfolder named "screenshots" at  the same location where the
bundle is located.
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Split bundles

In case multiple translators wish to work on the translation project at the same time,
Passolo gives the possibility to split the bundles into equal parts (based on the word
count). A bundle can only be used by one person at any one time, so please contact your
Project Manager if you need to split bundles before starting the translation.

1. Select Home > Statistics

This will show the statistics.

Notes:
1. Use "Copy to Clipboard" to copy the statistics to the clipboard. It is possible to

paste them in Excel.
2. Fuzzy matches are displayed in the statistics only if Pre-translation has been

performed on the bundle beforehand.

2. Contact the project manager in case the project size is too large to complete the project
in time.
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Translate

This section will describe how to translate texts in a translation bundle. When ready, you
can return the translated bundle to the project manager.
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Checklist

Checklist for Translators

Before translation:
· Make sure that the Translation Assistant is activated. 
· Connect the right Translation Memory (if provided by project manager).

While translating:
· Request split bundles from the project manager (if needed).
· Perform pre-translation based on the translated strings of the project or with the help of

the connected translation providers.
· Try to understand the context 

o with the help of the Comments,
o by calling up the Text Display window,
o by opening the screenshots or the live website.

· Check the Fuzzy match or Concordance search results
· Translate the strings.

After translation:
· Run the Check All Strings quality report on the bundle and correct any upcoming errors.
· Run the Statistics report to make sure that all strings are 100% translated and

validated. 
· Update Translation Memory (only if requested by the project manager).
· Close bundle before advising Project Manager of translation completion.
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Translate the bundle

The  Rigi addin for SDL Passolo has two main objectives:
· Support various file formats and requirements
· Provide a WYSIWYG (What You See Is What You Get) localization environment, a.k.a.

visual localization 

In addition to the SDL Passolo standard functionality, translators can use the WYSIWYG
localization environment if it is available for the project (Live website, Screenshots).

In the following section you may follow the steps for translating with the standard SDL
Passolo 2015 tool.

1. Start SDL Passolo Translator Edition

2. Select File > Open

3. Select the bundle (extension .tbulicnn)

4. Double-click the language in the translation bundle panel.

This will open the bundle.

5. Click the Show resource button to enter the preview mode (alternatively you can also
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double-click Rigi.Solution > "Strings" in the Resources panel):

This will open the preview.

The dropdown control on the top left of the preview enables various views. The views
that are available depend on the project that the project manager has prepared. The
supported views are:

o Rigi Server. When you select a string in the string list, the preview will be
retrieved from the Rigi server. Ask your project manager for access rights to the
project.

o Live. Browse the live web-application and localize it in context on-the-go.
o Translate. This is similar to Rigi Server, but in this mode the previews are stored

locally on disk.
o Review. All available previews that are stored on disk are shown and

translations can be entered WYSIWYG.

6. Select one of the views.

This will show the preview where the selected string is highlighted. In the example
below, the text "All" with ID "piwik.Core.General.Add" is used twice on the same
preview.
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7. Select an untranslated string.

Note: you can use the Filter option in Passolo to select certain strings. There is a pre-
defined filter to select all untranslated strings, but you can also define your own by
clicking "Define...".

8. Enter the translation (to the third box in the Properties window, by default in the bottom
right corner)

The changes are immediately reflected in the preview:
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Not all strings have a preview. There are alternative ways to understand the context,
such as the Text Display window, or the comments under the Comment column of the
string list (if available).

9. Hit Enter or click on the blue arrow pointing down to jump to the next Untranslated string

10. On the string list window click on Filter  ,  and in the drop-down menu choose
Untranslated strings.

Note: if you encounter instabilities with Passolo (e.g. freeze of the application), please
change the filter settings in the Rigi addin, see Filtering may freeze Passolo.

Translation helpers

Passolo offers numerus aids to ease the localization process.
· Translation assistant to let Passolo suggest translations.
· Fuzzy matches to leverage from existing translations.
· Updates on source text to show the history of a specific software string.
· Pre-translation to translate untranslated strings in batch mode.

Translation assistant

The translation assistant in Passolo makes sure that Fuzzy Matches will appear
automatically in the Translation window.

1. Select File > Options > Translation Assistant
2. Check "Use Translation Assistant"
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The option needs to be set for the first time. You may avoid repeating these steps every
time you start Passolo by activating the Restore last string list display when opening a
project functionality.

1. Select File > Options...

2. Select View

3. Check "Restore last string  list display  when opening a project" (note that the default of
this checkbox is disabled)
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The same option is available directly at the Passolo start page

Translation memories

In order to improve the concordance search or perform pre-translation, you can also
connect to Trados Studio server-based TMs.

Pre-requisite: SDL Studio is installed on the machine. Adding Trados Studio TMs to
Passolo is allowed by the tool only if SDL Studio is installed on the machine.

Be aware that SDL Passolo connects translation memories on a tool level and not on
bundle level. Translators always need to double-check first what memory is activated in the
tool, so that the correct translation memory can be used and updated with the correct
bundle.

Setup

Execute the following steps to setup the translation memory for your project.
 
1. Select Tools > Add-ins > Translation
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2. Select SDL Trados Studio

3. Click Setup...

Note: alternatively you may access the TM setup from File > Options > Pre-Translation

4. Click Add Translation Memory
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Details of exact Translation Memories to use for particular projects will be provided
by Project Managers).

Notes
o the memory connection only works if the language combination of the memory

matches the matches the language combination within Passolo (e.g. en-US <->
de-DE).

o If the source language does not have a locale (e.g. de, it, fr instead of de-DE, it-
IT, fr-CA, fr-FR), then even in these cases you can use the memory connection if
during the memory setup you select the memory and then activate the check box
Accept translation memories that only match the general language pair.

5. Enter the TM specific details, such as activate the TM for Update and Concordance (if
applicable)

Update

As a translator you want to make sure that the translation memory gets updated with your
changes.

1. In order to update any translation memory, make sure the box Update is checked in the
Translation Memory Setup window during the Setup process:

Note that Reference memories that are set for a read-only access level cannot be
updated via Passolo.
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2. Select Home > Translate

3. Click Store Translation 

The following pop-up window appears:

Check Send to translation add-in and select the adds-in as SDL Trados Studio, and
make sure you choose the option Add new translation units.
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4. Click OK.

Heads-up: The language direction of the Translation Memory has to comply exactly to the
language direction of the Passolo project. Unfortunately, no error message is displayed
when you connect a Translation Memory, which does not fulfill this requirement. BUT you
can recognize the discrepancy when you try to store a translation in the TM, the option is
simply greyed out if the language directions are no matching.

Fuzzy and concordance search

Use fuzzy search to search translations for similar strings or concordance search for
translations of parts of a source text. It is also possible to reuse old translations from the
recycle bin.

Fuzzy matches

Fuzzy matching provides translations for similar source strings (not exactly the same) that
were translated in the past.
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Setup

Configure Passolo to use the fuzzy matches from the current project: enable the translation
assistant and use the current project for fuzzy matching.

1. Select File > Options...

2. Check Use Translation Assistant (if not done already)  

3. Check Current Project under Fuzzy Matching:

Note that it is possible to select more sources than the current project for fuzzy
matches. Origins of Fuzzy Matches can be: connected translation memories, already
validated strings from the actual translation project, Recycle Bin of the project for not
used strings. See the Passolo documentation. 
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Using fuzzies

When fuzzy matching is enabled, Passolo will provide suggestions while translating.

1. Select an untranslated string in the project.

The translation tab will show the fuzzy matches:

2. Right click the option that you want to copy.

With right-clicking on the match, translators have 3 options:

- Write to Translation List: This option will write and submit the selected translation.
The status of the string will change from Untranslated to Pre-Translated.
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- Write to Translation Window: The option will write the selected translation into the
Translation Window. The translator can edit the string.

- Copy Translation: This option will copy translation to the clipboard and the translator
can paste it into the translation window (either with Ctrl+V or with right-click and Paste).

3. Adapt the translation to make it accurate.

Please note that parts of matches cannot be copied to the translation window, only the
full match. As a workaround, you can use the option Copy to Translation Window and
edit the fuzzy match in the Translation Window.

 

Concordance search

Concordance will search for a string where the words appear in the same order.

If the Origin is the translation add-in, then it is possible to do fuzzy concordance matching.
Check the settings for concordances by navigating to File > Options > Concordances à
Settings: it mentions ‘used only by the translation add-inʼ at the minimum match
percentage.
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Recycle bin

Passolo will move strings that are not used to the Recycle bin. You can set the fuzzy
matching/concordance to also look in the Recycle bin under File > Options > Fuzzy
Matching / Concordances.

The translations in there are valid.

Updates on source text

The properties window within Passolo will let translators know if there has been any change
in the source text. All text changes are highlighted.
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You can see the string modification history by navigating to the Properties window History
tab.

Please note that the translation bundle needs to be saved first to see the freshly entered
modification also in the history tab. Also, you need to click away from the selected string
and then navigate back.

The History tab shows all changes that were made to the string, with date and user name (if
available). 

The icon on the left indicates the type of change that was made:

 
The Changed column shows which data fields were changed (String, Status, Comment,
Property etc.)

Pre-translation
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Passolo offers the pre-translation function that uses matches from the translation providers
for selected strings. A translation provider can be a translation memory that is connected to
the tool or even the translated strings of the same or other opened bundle.

Please always check with your Project Manager (if not stated in the kick-off email) whether
pre-translation is recommended or not.

A pre-translation operation intends to find the translation based on the source text.

Before performing pre-translation on selected strings, please always check whether you
have the necessary translation providers connected/activated.

1. Select File > Options > Pre-translation

2. Select the sources from which to pre-translate.
Optionally you may include the strings from the Recycle Bin (strings that are not used,
have been replaced during the source update) or Other Opened Projects.

By selecting one of the above options and clicking on Setup, you have the possibility to
finetune the settings, e.g. for Current Project:
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3. Click on Home > Pre-translate

The following dialog appears:

4. Select the option that suits you the most: you may pre-translate only selected strings, or
the entire string list.

Note: by clicking on Options in the pop-up window you are navigated to the same Pre-
translation settings page mentioned above.

5. Click OK
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This starts the pre-translation process.

6. If multiple translations are found for a source text, Passolo offers the option to choose
from the translations:

7. All pre-translated strings will get the status “pre-translated” that requires
validation/review from to the translators. Fuzzy matches from the translation memories
will also get the “pre-translated” status.

IMPORTANT: Always review and validate the pre-translated strings to make sure that
the provided translation fits the context and is aligned with the project requirements,
terminology etc.

Terminology

To keep a translation consistent, translators can use a direct connection to a MultiTerm
database (Termbase). A red bar above a term shows that the term is contained in the
MultiTerm database. By right-clicking on the term a context menu is shown.
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All available proposals are shown at the top of the context menu. When placing the mouse
on one of the proposals a terminology window appears.  Select Look up...to open the entry
including additional information in MultiTerm.

Please contact your Project Manager to see if your project requires the use of a MultiTerm
connection or not. The approach might be different for certain products.
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Rigi Dashboard

The Rigi dashboard provides you a customized interface to easily access all visual
localization features in Passolo once they become available. You can customize the layout
and select from various views.
Layout

Rigi has powerful layout capabilities and eliminates the need to use the Resource Position
feature in Passolo.

Rigi provides an improved screen layout engine. There is no need to use this feature
with Rigi.

It is recommended to explore the layout possibilities. You can drag a tab or panel anywhere
on your display and see for example the live preview maximized on your second monitor.
When you click a tab (or panel), keep your mouse pressed and start dragging, a menu will
appear that helps you to organize the screen:

Views

Rigi server

The Review server is to store previews in the cloud. 
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This view is only available if the previews for this project are stored on the Rigi server.

1. Select the Review server view

This will open the connection to the Rigi server:

2. Enter your credentials (Your project manager can provide them).

Passolo will now get the preview from the server for the selected string and show all
available translations in the preview:
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3. Select a string in the string list and the previews on which it appears will be shown in the
preview. A string can appear on multiple previews. In that case, you can navigate
through them using a next/previous button.

If no preview is available for a selected string, a message is displayed instead:

4. Select a string in the preview and it gets selected in the string list. Change the
translation in the string list and you see the result immediately in the preview.

Live

The Live mode is to navigate a staging server with Rigi enabled and do translations in real-
time. All translations are stored in the Passolo project.

This view is only available if this projects supports localizing the live application. This view
is for example not available in case if your project is to localize a WPF desktop application.

1. Select the live view

This will open the live web application.
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2. Select a string in the preview and it gets selected in the string list

3. Change the translation in the string list and you see the result immediately in the
preview.

Translate (offline)

In Translate-mode, Passolo will get the translations from previews that are locally stored on
disk, see Offline. This view is only available if previews are stored locally.

Note: in case you have many screenshots, the performance of Passolo may go down.

1. Select the translate view

This will open the Screenshots-panel:
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2. Select a string in the preview and it gets selected in the string list

3. Change the translation in the string list and you see the result immediately in the
preview.

Review (offline)

In Review-mode, Passolo will get the translations from previews that are locally stored on
disk, see Offline. This view is only available if previews are stored locally.

Note: in case you have many screenshots, the performance of Passolo may go down.

1. Select the Review view

This will open the Screenshots-panel:

All screenshots for this project are shown in the panel.

2. Select a preview in the screenshots  panel.

The preview will be loaded.

3. Select a string in the preview and translate it.
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Quality check and delivery

Before the delivery of the translated project we highly recommend to perform build-in
quality checks. The project manager has configured the settings for this bundle.

1. Verify that all resolved texts are linguistically correct and adapt the translations where
needed.

2. Select Review > Check All Strings

3. Inspect the messages and resolve the issues. When the check is completed, a box will
appear on the bottom-left corner of the screen listing all errors/warnings.

4. Select Home > Statistics
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Make sure that 100% of the strings are translated and validated.

5. Click Close

6. Return the translated bundle to the PM

If you are working with split translation bundles, make sure you repeat all these steps for
each bundle before confirming project completion.
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Tips and tricks for translators

Please find below various tips and tricks for translators.
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Special characters

To select special characters, you can use the Windows character map program
(charmap.exe).

1. Windows menu > Open the Windows search button

2. Type charmap

3. Start charmap.exe

4. Select the character that you need and Copy it to the clipboard.
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Translation progress bar

The translation progress can be tracked via percentages and it is always based on the
total volume of the project. The progress bar shows change proportionally to the volume.

Select Home > Statistics for detailed information.
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Search function

To search within the Passolo project click on Home > Find. You can also use Ctrl+F to call
up the same search window.

Click to More button to specify the location of the search by selecting Source text,
Translation text or in many cases using the String ID is the most efficient way to find
something quickly.

After entering your search phrase, you may decide to find only one instance of the
searched phrase by selecting Find next and press F3 to jump to the next occurrence.

Select Find all to list all occurrences of the search term.
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Navigation between strings

The shortcuts Ctrl+Up and Ctrl+Down bring translators to the next/previous Untranslated
string. This can be customized under File > Options > Translation Assistant.
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Sorting strings

Click on View > Sorting.

There are several possibilities to arrange the sorting: By Resource, By Number, By ID, By
Source Text, By Translation Text, By Comment. Same sorting can be done by clicking on
the column label in the Strings window.
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Filter for strings

The Filter option at the top of the Strings window ( ) is useful to search for strings
with different status. By selecting Define a customized filter can be created. Please note
that jumping from resource to string functionality does not work with applied filters on.

Filters can be removed by clicking on the Remove Current Filter button:
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Copying a placeholder or a tag

In the source text you may often meet with placeholders or tags. With Passolo you can just
drag and drop for example a placeholder from the source text line into the translation line
within the Translation Window. You may also use the same drag and drop technique to
change the position of the placeholder or tag (if needed) within a long string.

Drag and drop from source to target
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Known issues

Known issues regarding Passolo and Rigi are mentioned below.
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Filtering may freeze Passolo

A bug in Passolo 2015 and 2016 up to build 373 causes instabilities with filtering.

If you filter strings using , and then navigate to the preview, Passolo may completely
freeze! SDL fixed this bug in Passolo 2016 buid 373.

Rigi implemented a workaround, which is disabling the filtering capabilties while the
preview is opened. If the version is below build 373 in Passolo 2016, the user will get the
following option via the Rigi settings (Tools>Addins>Rigi>Setup…):

It is recommended to uncheck the checkboxes. The Rigi addin supports limited filtering

capabilities via filter buttons ( ).
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